ScadaBR 1.1 com Ubuntu, Java8, Tomcat8 e MariaDB


#42

Retorno aqui depois desse longo tempo para agradecer imensamente ao amigo Alex, que fez vários vídeos para a instalação do ScadaBR no Raspberry Pi.

Finalmente consegui instalar o programa adequadamente, e tudo graças a estes tutoriais!!

Aparentemente, no raspberry só consegui rodar com o Java e Tomcat nas versões 7…

Agradeço a todos pela ajuda e atenção nas dúvidas e precisando de qualquer coisa estarei aqui!


#43

Bom Dia, poderia me disponibilizar a versão o Scadabr.war 1.1?


#44

Aguardem que nos próximos dias deve sair na área de downloads.


#45

Prezados, estou a tentar instalar o ScadaBR 1.1 seguindo à risca o tutorial numa máquina virtual usando o VMWare com o Ubuntu 16.04.03 e de jeito nenhum fica funcionando. A edição com java 6 e o ScadaBR 0.9 funciona muito bem e instala super fácil.

Queria usar a versão ScadaBR 1.1 para simular o ambiente de produção. Existe diferença se rodar numa máquina virtual? Quero muito contribuir para divulgar o software, mas a instalação se revela muito difícil para pessoas iniciantes e até avançadas. Gostaria de saber se tem alguma FAQ para problemas típicos numa instalação e a quem recorrer?

Como poderia ajudar para melhorar esta questão?


#46

O script que criei foi para usar o ScadaBR 0.9 do site padrão, pois não tenho ideia da versão 1.1

Voce poderia me mandar uma msg pvt para eu tentar te ajudar.
Olhe os logs do tomcat mango.log e catalina.out para tentar encontrar uma luz.


#47

@joaocampos

Consegui instalar no Ubunto 16.04 usando o Java8 e o tomcat7 e setando o banco de dados como Derby.

Rodou Legal e sem nenhum problema.


#48

@Felipebenevides Eu não consegui de jeito nenhum. Instalei o tomcat8, não funcionou. Depois desinstalei o Ubuntu e de seguida instalei com o tomcat7. Ainda tentei com o Ubuntu Server na máquina virtual também não deu certo. Você seguiu à risca o tutorial ou fez algum pequeno passo diferente?

Você usou Ubuntu 32 bits ou 64 bits?


#49

@joaocampos fiquei algumas semanas quebrando a cabeça.

algumas partes. Apanhei muito para conseguir instalar devido estar tentando usar o Mysql e não conseguir conexão com drive jdbc. Como estou com meu projeto atrasado e por isso optei por usar o Derby mesmo.

instalei o ubunto mate para o rasp e ja veio o java 8 instalado… baixei o tomcat 7 e instalei. peguei o arquivo scadabr.war no site do scada-lts e modifiquei o aquivo env.properties para aceirar o Derby como padrão e após isso rodou legal.

OBS: esse arquivo fica dentro da pasta do scadabr/WEB-INF/classes/env.properties

Coloquei as seguintes configurações no env.properties

db.type=derby
db.url=~/…/…/bin/scadabrDB
db.username=
db.password=

convert.db.type=
convert.db.url=
convert.db.username=
convert.db.password=

api.authentication=disabled
api.username=admin
api.password=admin

e após reiniciei o tomcat7 e funcionou.

depois me fale se funcionou.

Abraços.


#50

Consegui instalar o Scada no Ubuntu, mas somente o ScadaLTS usando o Docker, foi muito fácil a instalação. Vou ver se faço uma video aula e depois posto aqui!


#51

Amigos, após um tempo, fiz uma nova instalação do sistema agora usando o Lubuntu 17.04.
Parece que nossos amigos da Oracle ainda não colocaram o caminho para a instalação do Java8 no repositório dessa versão, portanto siga os seguintes comandos antes de instalar o java nas novas versões do Ubuntu:

su -
echo “deb http://ppa.launchpad.net/webupd8team/java/ubuntu xenial main” | tee /etc/apt/sources.list.d/webupd8team-java.list
echo “deb-src http://ppa.launchpad.net/webupd8team/java/ubuntu xenial main” | tee -a /etc/apt/sources.list.d/webupd8team-java.list
apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys EEA14886
apt-get update
apt-get install oracle-java8-installer
exit

Funciona.


#52

Caro Jonathanl.Avila

Segui suas instruções a risca (várias vezes) utilizando os arquivos disponibilizados por você, mas não obtive sucesso na instalação. Já refiz a instancia no AWS, utilizei vários pacotes do scadabr, e recebo sempre

Alguma sugestão ou atualização???

Obrigado
Pedro A. Peres


#53

Olá. Aqui também não rodou. Segui todos os passos e cheguei ao mesmo ponto que o @entersystem postou.

Tentei iniciar a aplicação manualmente usando o Tomcat Web Application Manager e recebo a mensagem:

FAIL - Application at context path [/ScadaBR] could not be started.

Pelo que entendi a versão que funciona é somente a v1.1.

Onde posso baixar essa versão? Alguma outra sugestão?


#54

eu estava com o mesmíssimo problema.

desinstalei o Ubuntu, reinstalei e executei um script que criei.
Voltou a funcionar normalmente, tive que refazer as telas gráficas do projeto, mas de resto, voltou a funcionar normalmente.
Se quiserem, posto o script e ensino a usar.