Not able to deploy ScadaBR on Amazon EC2


I tested ScadaBR online on Jelastic for a copuple of weeks. It worked great. So I thought of moving something more powerful and reliable and chose Amazon's EC2. I have two instances on it, one running Ubuntu and the other running Amazon Linux. I have OpenJDK 7 on Amazon Linux and OpenJRE 7 on Ubuntu's instance. They botth have Tomcat7 installed as well. I have uploaded ScadaBR to the webapps folder of Tomcat7. I'm able to get the Tomcat7 welcome page on both the instances' 8080 port. But when I put the /ScadaBR suffix, I get a 404.

I tried with .war on both instances, and this is the same file that I had deployed on Jelastic. All the paths pertaining to Java are set. I'm not able to understand what I'm doing wrong. Any suggestions would be great!


Sunny Srinidhi

i think that you have to change JDK7 for JDK6, normally jdk7 has problens with scadabr, i think that .pehaps it will solve you problem.

I have tried the following combinations:

Amazon Linux with JDK6 and Tomcat6

Amazon Linux with JDK7 and Tomcat7

Ubuntu with JDK6 and Tomcat6

Ubuntu with JDK7 and Tomcat7

But I have not been able to deploy on any of these.

The problem was with Tomcat installation on a Linux instance. We uploaded a zip file of the tomcat server installed on a local Ubuntu machine and then unzipped it on the server. Copied the ScadaBR tool to the webapps folder of this tomcat installation, and its working fine on the public DNS. Hope this helps others looking for the same solution.