Instalação do ScadaBR no Raspberry


#1

Segue os videos tutoriais para instalação e configuração do ScadaBR na plataforma Rapsberry

Parte 1 - Acessando Via SSH o raspberry

Parte 2 - Instalando o JAVA 7

Parte 3 - Configurando o JAVA7 para ser a versão oficial do JAVA no raspberry

Parte 4 - Instalação do Apache Tomcat

Parte 5 - Instalação do MySQL


ScadaBR 1.1 com Ubuntu, Java8, Tomcat8 e MariaDB
#2

@alexleandrom,

Esse tutorial foi Fantástico. Por isso você ganhará uma nova medalha.
Isso é muito bom para ganhar crédito junto à comunidade.
Parabéns.
Por coincidência estou com o meu raspberry na mesa. Vou testar tudo e dar um retorno.


#3

Vou tentar aqui também e dar um retorno.

Quanto ao usar o tomcat 8 com o java 8 será que é a mesma metodologia para instalar no raspberry?


#4

@alexleandrom,

até agora deu tudo certo no meu também.
Estou aguardando o video final para deixar o raspberry ligado o tempo todo.

Ta sendo ótimo seus videos.


#5

Segui o tutorial para instalar o ScadaBR em um orangepi com armbian, porém ele não está rodando. Pelo manager do tomcat, não consigo da o start também. O erro é de acesso negado (404). Alguém poderia me ajudar com esse problema? obrigado desde já.


#6

@PedroSantos Consegui instalar usando o Debian. Porem ainda n sei se é inferior ao Mysql.


#7

Você seguiu o tutorial?


#8

algumas partes. Apanhei muito para conseguir instalar devido estar tentando usar o Mysql e não conseguir conexão com drive jdbc. Como estou com meu projeto atrasado e por isso optei por usar o Derby mesmo.

instalei o ubunto mate para o rasp e ja veio o java 8 instalado… baixei o tomcat 7 e instalei. peguei o arquivo scadabr.war no site do scada-lts e modifiquei o aquivo env.properties para aceirar o Derby como padrão e após isso rodou legal.

OBS: esse arquivo fica dentro da pasta do scadabr/WEB-INF/classes/env.properties

Coloquei as seguintes configurações no env.properties

db.type=derby
db.url=~/…/…/bin/scadabrDB
db.username=
db.password=

convert.db.type=
convert.db.url=
convert.db.username=
convert.db.password=

api.authentication=disabled
api.username=admin
api.password=admin

e após reiniciei o tomcat7 e funcionou.

Abraços.


#9

@Felipebenevides
e o que já achou amigo do LTS?
Posta um print ai.


#10

Consegui rodar o programa usando o Tomcat 7. Ainda não confirmei se o banco de dados está funcionando.


#11

Consegui instalar no raspberry pi 3 seguindo o tutorial. Tudo está funcionando de acordo, mas quando vou criar uma representação gráfica e adiciono um componente gif, ele não me deixa escolher nenhuma imagem, fica em branco.
Testei importar um pronto que eu tinha no meu pc, ele importa tudo certo menos os gifs.


#12

Nossa, vou testar isso agora.


#13

Bom dia, estou iniciando no raspberry, poderia postar o link do tutorial de como configurar o raspberry para realizar estes procedimentos.


#14

Já está la no inicio do post. É um conjunto de quatro vídeos.


#15

Olá amigo, poderia criar um tópico explicando como instalar o Scada LTS? muito obrigado!


#16

Boa Tarde galera!!

Primeiramente parabéns pelos vídeos, é de pessoas assim que precisamos neste pais!

Minha duvida é a seguinte, a instalação no vídeo foi feita em base do Raspbian?? Caso eu utilize o Ubuntu Mate terei algum problema?

E por ultimo…destes 2 S.O qual vocês recomendam para utilização do ScadaBR no Raspberry? Caso seja algum outro além destes dois gostaria que falassem também.

Obrigado!


#17

@felipedejano,

Não sei dizer a diferença amigo, mas tenho dois outros amigos que estão testando cada um deles, na tentativa de termos uma opinião formada.
O raspbian tem parte gráfica, o que talvez possa ser desprezado se o objetivo é só servir o ScadaBR.


#18

Tem uma instalação do Raspbian que vem sem a parte gráfica,
ajuda muito no desempenho do ScadaBR
no próprio site tem como baixar as duas versões.

RASPBIAN STRETCH WITH DESKTOP
RASPBIAN STRETCH LITE


#19

@alexleandrom,

ótima sugestão. Vou brincar com essa versão lite. Saberia dar uma opinião de quanto se ganha de desempenho com a versão lite?


#20

Pessoal, segui o tutorial conforme o vídeo, ocorreu tudo bem!

Porém após eu ter jogado a pasta ScadaBR.war dentro da webapps do apache ainda não tenho acesso ao sistema, o tomcat está ok, mas sem sucesso ao abrir o Scada ainda.

Alguém sabe como proceder?

Detalhes: Estou usando a Versão 1.0 CE (Se alguém tiver link da 1.1 gostaria de receber)
Durante a instalação do MySql aquela tela azul para configuração da senha do root não apareceu para mim.
E durante a instalação do TomCat por eu ter buscado o link no site como demonstrado e por já haver uma nova versão ele instalou como MariaDB, porém os comandos de criação do banco e tal deram certo.