IEC101 data source does not open serial port to use


Hi, some months ago I tried to connect some instrument to the ScadaBR via MODBUS RTU and I found it easy and handy… this week I wanted to try IEC101 Serial but I was not successful. I checked the proposed COM port and I saw that the configured port is closed and ScadaBR did not open it to use. the other thing that happened is that after adding IEC101 to data sources and trying to enable that an error message appeared, however after restarting the ScadaBR the enable indication was green in spite of the assigned port was close yet. I just wanted to know that does the IEC101 driver work properly or is there any problem with the data source configuration which I had performed? I checked it with both Windows 7 and 10, with IEC101 serial simulator using virtual com port and with real physical device with real COM port. the same things happened to me and there was not any serial port recruited by the ScadaBR.


Are you using Scada 1.0/1.1 or 1.2?

ScadaBR can use only one serial at time. Let me explain more, one Serial instance for time. If I have three Serials on same computer, Scada can handle one serial only at time. you will need turn of the datasource serial to change to another…

Scada 1.0 and 1.1 sometimes when you turn-off the serial to change to anoter port, you cannot open the second port because the older port still opened at Java Driver, and if you disconnect the serial off to connect again, sometimes the ScadaBR hangs and you will need stop the Tomcat server for 3 or more minutes before try again… Its a Java issue with SerialRXTX driver on ScadaBR 1.0 and 1.1
I think is better you put your modbus at ethernet port or use a software or hardware Bridge to modbus ethernet/serial outside ScadaBR to permit you use the IEC101 or another serial controlled by ScadaBR. Its my suggestion…


Hi and thank you for your quick answer, I checked it at the time I wanted to use IEC101. I worked over a new PC station for IEC101, I mean I just added one serial port for the IEC101 and there was not any other data source ype such as MODBUS. as soon as I wanted to enable the data source an error message appeared and when I checked the port I found it close. I uninstalled the ScadaBR and installed it another time but the same problem occurred when I added an IEC101 serial.