Erro ao comunicar o ScadaBR com Arduino UNU


#1

Estou tentando fazer um projeto que preciso comunicar o Arduino com o ScadaBr utilizando o Mudbus Serial, porem ao tentar adicionar um novo Data Source aparece esta mensagem “Check that rxtx DLL or libraries have been correctly installed”. Procurei aqui no forum o que precisava fazer e achei várias instruções, porem nenhuma funcionou quando tentei aplicar. Vocês sabem oq posso fazer para conseguir realizar esta comunicação ?


#2

Boa noite,

Este problema está relacionado com a biblioteca de comunicação serial do ScadaBR (RXTX). Eu recomendaria, se for possível, que você migre para o ScadaBR 1.2, que já utiliza outra biblioteca serial mais moderna.

Caso você esteja usando o ScadaBR 1.1, é importante avisar que o protocolo Modbus Serial não está funcionando corretamente na versão 1.1.


#3

estou no meio de um case mas gostaria de nigrar para o scadabr 1.2, existe essa possibilidade?


#4

É possível. Migrar a partir da 1.1 é mais fácil, pois banco de dados não sofreu praticamente nenhuma alteração desde essa versão. Migrar da 1.0 pode ser um pouco mais complicado. Eu recomendo que você tente exportar os dados em JSON do ScadaBR 1.1, criar uma instância do ScadaBR 1.2 em outra máquina, importar o JSON e testar como fica.

Infelizmente eu não trabalho profissionalmente com o ScadaBR, então não cheguei a realizar na prática nenhuma migração da 1.1 para a 1.2.

Boa sorte!


#5

Muito obrigado! Irei instalar agora e passo um feedback. Estava utilizando a versão 1.0 ainda. Bem desatualizado


#6

Realmente com a versão 1.2 consegui comunicar tudo perfeitamente, muito obrigado !